码迷,mobileinhere.cn
首页 > web开发 > 详细

解决php redis扩展无法加载的问题

时间:2015-06-29 23:52:27      阅读:25583      评论:0      收藏:0      [点我收藏+]

标签:

最近在工作中需要使用php访问redis,从github.com/phpredis/phpredis下载了phpredis,并且按照官方的说明进行了安装

phpize
./configure [--enable-redis-igbinary]
make && make install

 

但是在重启php-fpm的过程中,发生了如下的错误,redis.so无法载入

[[email protected] modules]#  /usr/sbin/php-fpm
/usr/sbin/php-fpm: /usr/lib64/libssl.so.10: no version information available (required by /usr/sbin/php-fpm)
/usr/sbin/php-fpm: /usr/lib64/libcrypto.so.10: no version information available (required by /usr/sbin/php-fpm)
/usr/sbin/php-fpm: /usr/lib64/libcrypto.so.10: no version information available (required by /usr/sbin/php-fpm)
[29-jun-2015 11:14:43] notice: php message: php warning:  php startup: unable to load dynamic library ‘/usr/lib64/php/modules/redis.so‘ - /usr/lib64/php/modules/redis.so: undefined symbol: zend_new_interned_string in unknown on line 0
<br />
<b>warning</b>:  php startup: unable to load dynamic library /usr/lib64/php/modules/redis.so - /usr/lib64/php/modules/redis.so: undefined symbol: zend_new_interned_string in <b>unknown</b> on line <b>0</b><br />
<br />

 

试了网上一些解决方案,均无法解决问题。

实在没别的办法,于是打算重装php-fpm试试,遂去php-fpm.org/download/想下载个新版本的php-fpm,结果发现版本大于5.3.3的php内部已经集成了php-fpm,不用再另行安装了。

技术分享

于是用php --version查询了一下php的版本,已经是5.6.6了,

php --version
php 5.6.6 (cli) (built: mar  9 2015 13:27:38) 
copyright (c) 1997-2015 the php group
zend engine v2.6.0, copyright (c) 1998-2015 zend technologies

突然恍然大悟,自己一直用的是安装在另一个目录的php-fpm,和php并不是配套的

查看这个php-fpm的版本,发现是5.3.3

$/usr/sbin/php-fpm -v
php 5.3.3 (fpm-fcgi) (built: oct 30 2014 20:14:56)
copyright (c) 1997-2012 the php group
zend engine v2.3.0, copyright (c) 1998-2010 zend technologies

而php内部集成的php-fpm版本是5.6.6

$ /usr/local/php/sbin/php-fpm -v
php 5.6.6 (fpm-fcgi) (built: mar  9 2015 13:27:55)
copyright (c) 1997-2015 the php group
zend engine v2.6.0, copyright (c) 1998-2015 zend technologies

用php内部集成的php-fpm重启,成功!

root     18442     1  0 17:36 ?        00:00:01 php-fpm: master process (/usr/local/php/etc/php-fpm.conf)
nobody   30640 18442  0 18:04 ?        00:00:02 php-fpm: pool www          
nobody   31156 18442  0 18:05 ?        00:00:02 php-fpm: pool www          
nobody   32424 18442  0 18:08 ?        00:00:02 php-fpm: pool www

 

所以粗心害死人啊,以后在安装程序的时候需要多加小心,尽量显式的标明软件的版本,这样就会少犯这样的错误,少走弯路了。

 

另外需要注意:

  • 在php.ini中一定要配置extension_dir和extension,如:
extension_dir = "/usr/lib64/php/modules/"
extension=redis.so
  • phpredis编译出来的redis.so也需要拷贝到"/usr/lib64/php/modules/"中
  • "/etc/php.d/"中也要软连接redis.so,并且要创建一个redis.ini文件,内容如下:
$ cat /etc/php.d/redis.ini 
; enable redis extension module
extension=redis.so
  • 安装phpredis还可以通过命令
pecl install redis

 

解决php redis扩展无法加载的问题

标签:

原文地址:www.cnblogs.com/tenghuan/p/4608888.html

(6)
(5)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
2014 mobileinhere.cn 版权所有 京icp备13008772号-2
华人娱乐注册